Kanguru announces new support for MAC and Linux operating systems.

The FIPS 140-2 certified Kanguru Defender Elite currently works with:

  • Windows XP and above
  • Mac 10.5 and above
  • Red Hat 5
  • Ubuntu 10

Additional compatibility is in development for several other Linux distributions and connectivity options.

Written by Kanguru — October 31, 2012

Today's Schedule

The Very Latest From Kanguru

Stay informed about the most up-to-date Kanguru products, services, special events and insights on IT technology from leaders in the secure data storage and duplication industry.

visit Kanguru News visit GuruBlog